본문 바로가기

프로그램언어/자바

2차원배열에 대문자를 입력하고 소문자로 출력하기

3행 5열의 2차원 문자배열 형태의 대문자들을 입력 받은 후 소문자로 바꾸어서 공백으로 구분하여 출력하는 프로그램을 작성하시오.

 

입력 예]

A B C D E

F G H I J

K L M N O

 

출력 예]

a b c d e

f g h i j

k l m n o

 

소스코드

import java.io.*;

 

public class Main{

    public static void main(String[] args) throws IOException{

        BufferedReader in = new BufferedReader(new InputStreamReader(System.in));

        char [][] arr = new char[3][5];

 

        for(int i=0; i<3; i++)

        {

            for(int j=0; j<5; j++)

            {

                arr[i][j] = (char)(in.read());

                in.read();

            }

            in.read();

        }

 

        for(int i=0; i<3; i++)

        {

            for(int j=0; j<3; j++)

            {

                System.out.printf("%c ", arr[i][j] + 32);

            }

            System.out.println();

        }

    }

}

 

소스코드2

import java.util.*;

 

public class Main{

    public static void main(String[] args){

        Scanner scan = new Scanner(System.in);

        char [][] arr = new char[3][5];

        String tem;

        char aaa;

 

        for(int i=0; i<3; i++)

        {

            for(int j=0; j<5; j++)

            {

                tem = scan.next();

                aaa = (char)tem.charAt(0);

                arr[i][j] = aaa;

            }

        }

 

        for(int i=0; i<3; i++)

        {

            for(int j=0; j<5; j++)

            {

                System.out.printf("%c ", arr[i][j] + 32);

            }

            System.out.println();

        }

    }

}